Drive Order Creation and Fulfillment - Issue Detected

Incident Report for DoorDash

Postmortem

On May 14, 2025, from approximately 1:29 PM to 2:12 PM PST, a configuration change introduced a corrupted setting that decreased the availability of the Drive Classic v1 APIs. Our monitoring systems promptly alerted us to the issue, and upon identification, we initiated and completed a rollback to restore normal service.

The impact of this incident was limited to Drive Classic v1 APIs. Drive v2 APIs and order fulfillment systems remained fully operational throughout the incident.  To avoid recurrence, we have implemented stricter validation checks and enhanced change management procedures for critical configuration files related to the Drive Classic v1 APIs. We apologize for any inconvenience caused and appreciate your understanding.

Posted May 15, 2025 - 11:14 PDT

Resolved

This incident has been resolved.
Posted May 14, 2025 - 16:09 PDT

Update

We are continuing to monitor for any further issues.
Posted May 14, 2025 - 14:17 PDT

Monitoring

The issue is mitigated.
Drive V1 API saw 5xx errors between 1:30 PM PST and 2:10 PM PST.
If you saw errors with creating deliveries, please retry now and it should work.
Posted May 14, 2025 - 14:16 PDT

Identified

We have identified the issue. Team is working on mitigating.
Posted May 14, 2025 - 14:09 PDT

Investigating

We have detected an issue with Order Creation and Fulfillment. We are actively investigating.

Next update in 15 minutes.
Posted May 14, 2025 - 14:08 PDT
This incident affected: Drive (Drive API).