Marketplace order volume is down
Incident Report for DoorDash
Postmortem

Between 4:41 PM PST to 5:10 PM PST on 7/02, DoorDash experienced an incident that affected one of the critical databases. The incident was caused by a bad database query that couldn’t be run efficiently and led to other queries on this database slowing down and eventually timing out.

The issue affected all of DoorDash including Marketplace and Storefront orders and Drive deliveries.

The incident was mitigated after the bad query was reverted and existing query executions terminated.

Majority of the action items following this incident are focused on limiting the potential impact of bad queries on the overall health of our platform.

Posted Jul 15, 2024 - 15:16 PDT

Resolved
This incident has been resolved.
Posted Jul 02, 2024 - 17:56 PDT
Update
We are continuing to monitor for any further issues.
Posted Jul 02, 2024 - 17:45 PDT
Monitoring
Marketplace order volume is back to normal, the team is continuing monitoring the recovery.
Posted Jul 02, 2024 - 17:44 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 02, 2024 - 17:06 PDT
Update
We are continuing to investigate this issue.
Posted Jul 02, 2024 - 16:57 PDT
Investigating
We are currently investigating this issue.
Posted Jul 02, 2024 - 16:55 PDT
This incident affected: Merchant - Marketplace (Orders).