DoorDash Marketplace Volume Drop
Incident Report for DoorDash
Postmortem

On 7/2/2024, a breaking change was deployed causing the DoorDash Restaurant store page fully unavailable for IOS users between 12:39 PT and 13:13 PT. 

There were partial outages for the IOS app  from 11:45 PT to 12:39 PT,  and 13:13 PT to 13:32 PT, during the deployment of the breaking change, as well as during the rollback period.

This caused the drop in marketplace order volume. 

The team is working on a number of action items focused on preventing incidents like this from happening by introducing new guardrails against breaking contract changes, better observability and alerting for issues potentially caused by an ongoing deployment and making rollbacks quicker.

Posted Jul 15, 2024 - 15:15 PDT

Resolved
This incident has been resolved.
Posted Jul 02, 2024 - 13:43 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 02, 2024 - 13:35 PDT
Update
We have confirmed that this issue only affects restaurants and should not impact our retail and grocery partners. We are continuing to investigate this issue.
Posted Jul 02, 2024 - 13:26 PDT
Update
We are continuing to investigate this issue.
Posted Jul 02, 2024 - 13:13 PDT
Update
We are continuing to investigate this issue.
Posted Jul 02, 2024 - 12:58 PDT
Investigating
We are currently investigating this issue.
Posted Jul 02, 2024 - 12:55 PDT
This incident affected: Merchant - Marketplace (Orders).