On July 2nd from 4:40pm to 5:30pm PT DoorDash services were largely unavailable and fulfillment was degraded. This was caused by a configuration change to an internal system. The issue was partially mitigated at 5:05pm PT and error rates dropped for some endpoints. The issue was fully resolved and systems returned to normal at 5:30pm PT.
We are taking steps to reduce the risk and impact of such config changes.
Posted Jul 03, 2024 - 18:43 PDT
Resolved
The issue with Order Fulfillment is now confirmed to be resolved.
No further updates.
Posted Jul 02, 2024 - 17:55 PDT
Monitoring
The issue with Order Creation and Fulfillment is resolved but we will continue to monitor.
Next update in 15 minutes.
Posted Jul 02, 2024 - 17:45 PDT
Update
We are showing recovery across all endpoints, and order fulfillment is recovering.
Next update in 15 minutes
Posted Jul 02, 2024 - 17:36 PDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 02, 2024 - 17:27 PDT
Identified
We have identified an issue with Order Creation and Fulfillment. We are actively working on a resolution.