On 6/21/2024, between 6:40 AM PST and 7:21 AM PST, we experienced an issue with the Drive APIs resulting in degradation in Order Creation, and Updates. This issue was caused by an erroneous update at our traffic layer, which has since been resolved. The system remains healthy since 7:21 AM and we are taking appropriate actions to increase the resilience of our system to these types of events.
Posted Jun 24, 2024 - 17:35 PDT
Resolved
This incident has been resolved.
Posted Jun 21, 2024 - 08:19 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 21, 2024 - 07:32 PDT
Identified
We have identified an issue with Order Creation and Fulfillment. We are actively working on a resolution.
Next update in 15 minutes.
Posted Jun 21, 2024 - 07:24 PDT
Investigating
We have detected an issue with Order Creation and Fulfillment. We are actively investigating.