Doordash + Drive fulfillment - Issue Detected
Incident Report for DoorDash
Postmortem

On April 4th, Doordash experienced service degradation from 1:16 PM PST to 2:06 PM PST due to an issue with the traffic infrastructure. This issue affected our traffic routing fleet, resulting in connection failures for a certain percentage of incoming requests from Customers, Merchants, and Dashers on all platforms. We observed an increased error rate for Doordash Marketplace Orders, Storefront, and Drive Fulfillment as a result.

To resolve the issue, we reverted the changes and allowed our traffic infrastructure to stabilize. We are also adding guardrails to ensure that similar changes are rolled out gradually and do not cause similar issues in the future.

Posted Apr 24, 2024 - 13:01 PDT

Resolved
This incident has been resolved.
Posted Apr 04, 2024 - 14:15 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 04, 2024 - 14:08 PDT
Identified
We have identified the issue and working on mitigating. We are seeing partial recovery already.
Posted Apr 04, 2024 - 14:02 PDT
Update
We are continuing to investigate this issue.
Posted Apr 04, 2024 - 13:42 PDT
Update
We are continuing to investigate the issue. About 50% of traffic coming into Doordash seems to be impacted.
Customer tracking pages and Merchant portal are also impacted in some regions.
Posted Apr 04, 2024 - 13:40 PDT
Investigating
We have detected an issue with Order Fulfillment and are actively investigating.

Next update in 15 minutes.
Posted Apr 04, 2024 - 13:35 PDT
This incident affected: Drive (Drive API, Drive Order Fulfillment, Drive Delivery Tracking Page), Merchant Portal, Merchant Tablet, and Merchant - Marketplace (Orders, Dasher Status Updates).