From June 28th 4:15pm to June 29th 3:29am PT, DoorDash Drive failed to geocode and validate up to 10% of addresses. As a result, Drive's order rejection rate increased across all order validation and creation endpoints. The incident was resolved once Google's geocoding incident was resolved.
We are working to make our systems more resilient to geocoding failures.
Posted Jul 03, 2024 - 18:41 PDT
Resolved
The issue with Order Validation and Creation is now confirmed to be resolved.
No further updates.
Posted Jun 29, 2024 - 06:59 PDT
Identified
Google geocoding APIs had an issue which caused a lot of addresses to fail without state and country fields. This caused a lot of invalid_address errors on the Drive APIs. Google has updated that the issue is fixed on their end but would take a few hours for the changes to propagate to all regions.
Teams are continuing to monitor the errors. This mostly impacts addresses which do not have a street number and instead pass the street corner as the address. This seems to be true for a lot of Australia addresses.